loongnix下编译grub2缺少autopoint, yum install找不到

Can't exec "autopoint": 没有那个文件或目录 at /usr/share/autoconf/Autom4te/FileUtils.pm line 345.
autoreconf: failed to run autopoint: 没有那个文件或目录
autoreconf: autopoint is needed because this package uses Gettext
 
 
已邀请:

windows1089 - 百度贴吧龙芯吧小吧主

赞同来自:

yum search 一些关键词试试看呢?

doubletreeli

赞同来自:

编译时的报错信息:
autoreconf: running: autopoint --force
Can't exec "autopoint": 没有那个文件或目录 at /usr/share/autoconf/Autom4te/FileUtils.pm line 345.
autoreconf: failed to run autopoint: 没有那个文件或目录
autoreconf: autopoint is needed because this package uses Gettext
最后安装了:yum install intltool
没有这个报错了,看了网上一个帖子,没搞懂原因

hankinsea - Archlinux user

赞同来自:

Fedora系统里把autopoint打包到gettext-devel里了,fedora直接安装gettext-devel包

loongson_os

赞同来自:

1、根据编译时报错信息,没有autopoint这个可执行程序。
解决方法:loongnix系统下需要安装gettext-devel-0.19.2-6.fc21.loongson.mips64el软件包。
2、关于你的疑问:yum install intltool后,没有上述报错。
原因是:安装intltool时,gettext-devel作为依赖包被同时安装了。

要回复问题请先登录注册