找不到libssl-dev

Linux loongson-PC 4.19.0-loongson-3-server #1187 SMP PREEMPT Wed Mar 25 22:36:49 CST 2020 mips64 GNU/Linux 编译安装mysql5.7时报错:
Cannot find appropriate system libraries for WITH_SSL=system.
Make sure you have specified a supported SSL version.
Valid options are :
system (use the OS openssl library),
yes (synonym for system),
</path/to/custom/openssl/installation>

CMake Error at cmake/ssl.cmake:63 (MESSAGE):
  Please install the appropriate openssl developer package.

Call Stack (most recent call first):
  cmake/ssl.cmake:264 (FATAL_SSL_NOT_FOUND_ERROR)
  CMakeLists.txt:579 (MYSQL_CHECK_SSL)
 
$ sudo apt-cache search libssl

libssl1.1 - Secure Sockets Layer toolkit - shared libraries
perl-openssl-defaults - version compatibility baseline for Perl OpenSSL packages
找不到libssl-dev的包
 $ cat /etc/apt/sources.list
## Generated by deepin-installer
deb [by-hash=force] https://packages.chinauos.cn/uos eagle main contrib non-free
deb-src https://packages.chinauos.cn/uos eagle main contrib non-free
deb [by-hash=force] http://packages.deepin.com/deepin stable main contrib non-free
已邀请:

cyberhero

赞同来自:

試試 apt install openssl-dev

alex8158

赞同来自:

试过了,没有

cyberhero

赞同来自:

可以去下載deb包安裝,uos應該是debian10吧
https://packages.debian.org/buster/libssl-dev

要回复问题请先登录注册