lynloogn-2f-9003 灵珑一体机9s2a kernel pmon

    上个星期我问Lemote team lynloogn-2f-9003上可以用的kernel因为之前我编译所有的kernel pmon都只能load到 g启动系统时都失败了,Lemote team告诉我只有出场的kernel 2.6.27才能在一体机适配,主要sm502,其他都没驱动,意思就是无法升级内核,也就绝缘了很多系统的更新,我看了下kernel文档要求GCC 3.2,但是几乎无法找到mips64el gcc3.2也就无法编译 社区的是gs464核交叉编译器(gcc-4.4.7 64位)。。。编译提示makefile 过时的。
     我还尝试过gentoo,gentoo mips 下的stage3没有一个适合的,龙芯笔记本的那个完全不适合。无法chroot。于是我自己crossdev -t mips64el-unknown-linux-gnu 做了个satage3,不过chroot 提示kernel too old具体查看gentoo 论坛,不过查看到openbsd 支持lynloogn-2f-9003  openbsd 官网 不过安装时遇到LM9103-1.5.9不支持,于是想自己编译pmon安装但是编译错误 根据官方编译指南pmon-loongson3/zloader.2fdev.sm502  基于fedora21 i686 错误提示
VRAM_SIZE’ undeclared (first use in this function) 
    试过lubuntu i386也是这个错误。想文下lynloogn-2f-9003 pmon zloader.2fdev.sm502 正确与否,有bin提供或如何能编译完成?pmon升级也许就能安装openbsd了,有lynloogn-2f早期的交叉编译版本gcc么?这些都相对2.6.27都太新了。
    我知道龙芯2f很多年了,但是为啥资料这么少?官方社区基本是3A那些?一个遗留角落能都没有?我也知道百度但是那里看到的基本都是不维护的debain 6了虽然还能找到老旧源apt-get但是毕竟是不维护的了,要是能提供交叉编译早期版本或者pmon(lynloogn-2f-9003 )升级文件不胜感激。
 
 
已邀请:

jiangtao9999

赞同来自:

因为龙心自己都放弃这东西了。估计龙心会坚持mips64r2一段时间了。
2f是mips64的,好像应该算mips3 64bit。

vastchen - 如:80后IT男..

赞同来自:

make: *** [start_sm502.o] 错误 2
vast@vast-VirtualBox:~/pmon-loongson3/zloader.2fdev.sm502$ /pmon-loongson3/pmon/cmds/bootparam.c:526: error: ‘VRAM_SIZE’ undeclared (first use in this function)

flygoatfree

赞同来自:

Github上是我回复你的:)。。我是爱好者,不是Lemote或者龙芯的人
lynloong 9003的PMON在这里。因为龙梦和龙芯不是同一家公司,所以龙芯的PMON里自然没有部分Lemote设备的支持。https://github.com/kisom/pmon  (target 叫 2faio)
老PMON工具链用:http://ftp.loongnix.org/toolch ... ar.gz
内核工具链我也不清楚。不过这个内核版本也的确没啥办法。谁有兴趣的话我们可以把代码移到2.6.32上去这样至少我们有Redhat的backport成果可以蹭蹭,Debian8估计还是没问题的。
2F一体机出厂自带的共创Linux已经倒闭了。。这也没办法。

vastchen - 如:80后IT男..

赞同来自:

IMG_20180712_205053.jpg

刷pmon成功,感谢flygoatfree提供的链接编译成功刷上1.6.1了

要回复问题请先登录注册