编译node需要g++,但官方yum库没提供

make[1]: g++: Command not found

deps/openssl/openssl-cli.target.mk:188: recipe for target '/root/pkg/node-v8.9.4/out/Release/openssl-cli' failed

make[1]: *** [/root/pkg/node-v8.9.4/out/Release/openssl-cli] Error 127

Makefile:87: recipe for target 'node' failed

make: *** [node] Error 2

[root@7946efaa531a node-v8.9.4]# yum install g++

Failed to set locale, defaulting to C

No package g++ available.

Error: Nothing to do
已邀请:

heiher - 生态破坏者?

赞同来自: zzz19760225 loongnix

yum install gcc-c++

navyran

赞同来自: zzz19760225

参考这里可以安装: http://www.cnblogs.com/Anker/p/3203402.html

要回复问题请先登录注册