loongnix下不支持edup的无线网卡?

龙芯3a3000主板电脑,loongnix310的os,edup(rtl8818cus)网卡没驱动起来
此网卡为我玩树莓派时买的,在树莓上直接支持,但在loongnix上不能直接支持。请各位大侠指点,怎么解决,也请loongnix考虑加入这个网卡的适配。
已邀请:

iapcmloongson

赞同来自: zzz19760225

这个网卡Linux下应该是可以使用的。至少debian是可以用的
https://wiki.debian.org/rtl819x#supported-rtl8192cu

loognix自带的内核版本较低,你可以考虑升级一下内核到4.4.30,试试能否驱动你的网卡
http://ftp.loongnix.org/os/loongnix/1.0/kernel/RPMS/Packages/
 

wlxn

赞同来自: zzz19760225

该无线网卡驱动安装成功!
我并没有升级内核到4.4,但是用loongnix自带的升级工具更新的最新的系统。
然后我抱着试试的态度 ,重新执行了insmod xxxx.ko,竟然模块启动成功,网络管理器几秒后发现了无线网络,并成功连接,到目前为止,我也不确定是内核升级后成功的,还是就重启后重新试了一下就成功了。总之上次编译的模块可以用了。

下面将此驱动模块分享,见附件,希望对刚好和我情况一样的同学有所帮助。
如果想自行编译的话,请在如下地址下载网卡驱动源代码
http://www.edup.cn/dl/REALTEK/RTL8188CUS/linux%20.rar

但注意需要修改os_intfs.c文件为附件中的内容,因为内核3.10后版本,与3.9的有一些差异导致程序不兼容。而网卡厂商提供的源代码支持到3.9;另外修改原文件Makefile为附件中的内容,这主要是设定龙芯平台编译环境
 

要回复问题请先登录注册