(20170918)loongnix源里更新的软件包libgo的问题

今天执行sudo yum update时发现,有一个名为“libgo”的包可以更新。但是,依赖libgo的libgo-devel和gcc-go没有相关的更新,导致更新出错。
使用的软件源是http://ftp.loongnix.org/os/loongnix/1.0/os/
以下是执行sudo yum update时的输出:
[dou13@localhost ~]$ sudo yum update
已加载插件:langpacks
正在解决依赖关系
--> 正在检查事务
---> 软件包 libgo.mips64el.0.4.9.3-6.fc21.loongson.6 将被 升级
--> 正在处理依赖关系 libgo = 4.9.3-6.fc21.loongson.6,它被软件包 libgo-devel-4.9.3-6.fc21.loongson.6.mips64el 需要
--> 正在处理依赖关系 libgo = 4.9.3-6.fc21.loongson.6,它被软件包 gcc-go-4.9.3-6.fc21.loongson.6.mips64el 需要
---> 软件包 libgo.mips64el.0.5.2.0-5.fc21.loongson.1 将被 更新
--> 解决依赖关系完成
错误:软件包:gcc-go-4.9.3-6.fc21.loongson.6.mips64el (@fedora)
          需要:libgo = 4.9.3-6.fc21.loongson.6
          正在删除: libgo-4.9.3-6.fc21.loongson.6.mips64el (@fedora)
              libgo = 4.9.3-6.fc21.loongson.6
          更新,由: libgo-5.2.0-5.fc21.loongson.1.mips64el (fedora)
              libgo = 5.2.0-5.fc21.loongson.1
          可用: libgo-4.9.3-3.fc21.loongson.3.mips64el (fedora)
              libgo = 4.9.3-3.fc21.loongson.3
          可用: libgo-4.9.3-4.fc21.loongson.4.mips64el (fedora)
              libgo = 4.9.3-4.fc21.loongson.4
          可用: libgo-4.9.3-5.fc21.loongson.5.mips64el (fedora)
              libgo = 4.9.3-5.fc21.loongson.5
错误:软件包:libgo-devel-4.9.3-6.fc21.loongson.6.mips64el (@fedora)
          需要:libgo = 4.9.3-6.fc21.loongson.6
          正在删除: libgo-4.9.3-6.fc21.loongson.6.mips64el (@fedora)
              libgo = 4.9.3-6.fc21.loongson.6
          更新,由: libgo-5.2.0-5.fc21.loongson.1.mips64el (fedora)
              libgo = 5.2.0-5.fc21.loongson.1
          可用: libgo-4.9.3-3.fc21.loongson.3.mips64el (fedora)
              libgo = 4.9.3-3.fc21.loongson.3
          可用: libgo-4.9.3-4.fc21.loongson.4.mips64el (fedora)
              libgo = 4.9.3-4.fc21.loongson.4
          可用: libgo-4.9.3-5.fc21.loongson.5.mips64el (fedora)
              libgo = 4.9.3-5.fc21.loongson.5
 您可以尝试添加 --skip-broken 选项来解决该问题
 您可以尝试执行:rpm -Va --nofiles --nodigest
已邀请:

jiangtao9999

赞同来自:

请自觉改用 debian 。
不过 debian 的内核没办法启动系统。需要用龙芯系统的内核替代。
至于自己编译,我反正用 kernel.org 的主线内核失败。
不知道龙梦那边的内核有没有问题。懒得弄了,暂时龙梦有个 4.4.x 的内核可以用。

之前谁忽悠我 kernel.org 的主线内核早就行来的?

要回复问题请先登录注册