qemu 2.7.0版本的 loongson3a处理器 跑 linux内核

具体的问题是这样的,我参照龙芯网站的 qemu 项目的内容,想在qemu上跑一下龙芯系统的内核,下载相关文件,包括内核文件和交叉编译器等,然后运行了一下网站编写的脚本(图1),是可以跑的出来结果的(图2)。现在的问题是我想用qemu 2.7.0 的版本跑一下这个内核,因为2.7.0.的版本支持 loongson3a这个处理器,所以修改了脚本的参数,qemu的版本 以及处理器的参数(图3),然后运行结果为段错误(图4),所以想咨询一下具体原因是什么,要怎么可以用 qemu 2.7.0 版本的 loongson3a处理器来跑一下内核。万分感谢
捕获1.PNG 捕获2.PNG 捕获3.PNG 捕获4.PNG
已邀请:

loongnix

赞同来自:

http://www.loongnix.org/index.php/QEMU

DaDou13 - 普通用户

赞同来自:

直接下载编译好的内核试试,deepin或者龙梦的源里应该编译好的deb或者rpm包
packages.deepin.com
mirror.lemote.com:8000

要回复问题请先登录注册