网络学习管理系统Moodle-3.1.5安装失败

看到Loongnix网站上有一篇文章

《龙芯电脑上架设网络学习管理系统Moodle》

自己在Loongnix(2018.6.30)测试了一下,发现Mysql版本不够高:
[loongson@localhost ~]$ cat /.buildstamp 
[Main]
Product=Fedora
Version=21
BugURL=[url]http://bugs.loongnix.org
IsFinal=True
UUID=201806302100.mips64
BUILD=201807081210
[Compose]
Lorax=19.6.28-1
[/url]


Screenshot-安装_-_Mozilla_Firefox.png


而原作者并没有遇到这个错误。有人知道什么原因吗?
已邀请:

admin

赞同来自:

龙芯仓库里mysql数据库实际就就是mariadb-server这个包。版本信息:
 
mariadb-server.png

 
目前只能提供这个版本。
 
您可以试着不要自动安装,找到sql脚本,试试手动导入mariadb里面。

jiangtao9999

赞同来自:

这个喷龙芯开发组,他们觉得自己的软件版本足够了。就不考虑用户软件的问题了。
mariadb 升级到 10.1 应该就能解决这个问题。10.1 应该对应的是 5.6 的 mysql 吧?
即便用 mariadb 的 10.0 系列,最高版本也应该是 10.0.38 ,但是这龙芯也不提供。
 
降级使用吧。或者自己去找高版本的 mariadb ,这东西可以在 mips64el 上直接编译不需要支持补丁。

要回复问题请先登录注册