fedora 29 for mips64r2el 的 rpm

https://pan.baidu.com/s/1UnUzZFIEwh43doIOQQyibg
 
里面的 rpms-20181102 就是这些 rpm 的压缩包。
这是基于 fedora 29 的 devel 版本编译的。
我会用这些 rpm 尝试编译正式版的 fedora 29 。
里面的 java ,版本号 fc29.1 的是龙芯的 mips64el 版,没有这个 .1 的,是 fedora 自己的版本,加上 debian 的 zero 补丁编译出来的 zero 版,也就是完全架构无关无优化的版本。
里面的内核是 4.14 的,因为我没找到能用的 4.18 版,所以只好先用这个替代。(话说 loongnix 的网站还吹 kernel.org 的源代码能跑龙芯呢吧?实际上不能了啊。)
但是 fedora 29 的 firewalld (好像是这个)已经开始依赖 4.18 版了。
其实我曾经编译过 4.18 版的内核,但是不能启动,还引起了 mock 的工作不正常,好像是 libseccomp 没办法正确转换 4.14 和 4.18 的调用。所以只好去掉了。
 
希望龙芯能发布 4.18+ 的内核源代码,能启动的。不要抱着老版本了。尤其是 4.20 提升了 fuse 的性能,这很关键的。其实 4.18 就已经开始增加 fuse 的性能了。这对于龙芯肯定需要的 ntfs-3g 还是很有意义的。另外,内核 4.17 开始可以用 zfsonlinux 的内核模块版了吧?这东西也很好啊。龙芯做服务器,可以先从对 CPU 的需求不高的数据服务器开始啊。
 
欢迎大家用这个系统继续编译,不过编译 rpm 需要禁用 debugsource 的 rpm 生成。我看生成的脚本,似乎是调用 debugedit 输出文件这里失败,导致文件为空。我已经发了另外一个问题,也希望大家帮忙解决。
另外,哪位如果有服务器可以提供 http ,帮忙放个 repo 吧。
谢谢了。

0 个评论

要回复文章请先登录注册